Ex-500.com - The home of the Kawasaki EX500 / Ninja 500R banner
1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I can't seem to determine if this is normal or not and this may be abysmally obvious to some but at around 100 kmh (60 mph) or even a bit lower, the bike seems to struggle to even maintain its speed up a steep-ish hill even in lower gears with ~8500 rpm. I live right near the Canadian Rockies in the foothills, so the hills I'm experiencing this issue with are a bit on the steeper side.
I just got my 1999 ninja 500. It has had an unknown amount of previous owners, at least 3, most likely more and it has been down before (evident from scuffed fairings and replacement mirrors + signal lights). When I got it, it was not running (been sitting in a garage for 4 years) and I had a professional check out the carbs for me and I replaced all the fluids, so it should theoretically be in good working order. The bike has about 46500 kms on it and was evidently not treated the best during its lifetime (scuffed plastics etc. mentioned above).

I'm waiting on a spark plug socket so I can change out the spark plugs (I have iridium replacements), would that be of any benefit to my issue?
Is this simply normal behaviour for this bike and am I asking too much of the engine or not revving high enough (I am a beginner rider)?
Does it sound like a problem with fuel delivery? Like I mentioned above, I did just have a professional clean out the carbs and look over all the hoses and everything about a month ago.

[The reason why I'm on the fence about whether or not this is normal is because I read a lot of you guys talk about how you can easily pull from 75 mph to 90 mph on what I presume to be flat highways and while I haven't mustered up the guts to go quite that fast yet (I'll try going from say 60mph to 80mph soon on an empty highway to see if it really is lacking that normal pulling power and update) I can't imagine maintaining 60 mph up a steeper hill would be an issue for an engine that can do that.]
 

·
Registered
Joined
·
19,841 Posts
you didn't mention your altitude. if you are above say 3000 ft 914 m you might just have to leant your jetting. Heres where the FOG MOD can really help to lean out the mixture on top

FOG
 
  • Like
Reactions: po18guy

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Hey FOG, thanks for the quick reply, you are the real MVP. That makes a lot of sense, where I live the average altitude is about 1050m (3444 ft) and when I go to the fun roads the altitude gets even higher. I'll try the FOG mod since everything else on the bike was just refreshed and it doesn't feel like the carb is doing something it is not supposed to (no unexpected bogging or flat spots). I did some research and found out that peak power is at 9500 rpm, should I be revving the bike more on uphills? I've been stopping the revs at 8500 because of the noise + vibrations.
 

·
Premium Member
84' Goldwing Aspencade, 91' EX500, 98' Ninja 250/17' 300 engine, 07' EX500
Joined
·
3,845 Posts
Don't know if this will help, but my 91 EX had a similar problem, turned out to be a bad petcock. It wasn't allowing enough gas to flow when moving quickly, like it was running out gas, so to speak.
 

·
Registered
Joined
·
1,967 Posts
hi no it's not normal at all. while my location can nowhere near be described as the Rockies or even moderately mountainous (just a bit hilly) the average height above sea level on a country road is around 900mtrs. above sea level no issues at all here. question does it have a inline filter fitted. these can cause fuel flow issues. as well as poorly performing petcock.
 

·
Administrator
Joined
·
7,040 Posts
I hate to say it. I know you had a carb guy look at it. But it does also sound like a possible damaged or mal seated diaphragm.
 
  • Like
Reactions: ghostt

·
Registered
Joined
·
2,881 Posts
I rode my Yam TX650 through the Colorado Rockies, to my cousin's home at 10,250 feet. The engine felt quite soft, but with a downshift or so, it could still maintain highway speeds. You may have to run your bike on the new plugs and then read them. Look up how to do a "plug chop" as it will give you an idea of your mixture.

Also, make sure you do not have a mouse nest in your airbox. The OEM air filters are OK, but the foam in them tends to degrade and turn to bits. A Uni Filter or K&N will help there. Could be a hundred other things, but it sounds really rich.

Q: Are you a "big guy"?
 

·
Registered
Joined
·
127 Posts
From my experience with a good running ex it sounds like you have something going on. Road my bike a lot in the rockies and lived at 9,000 feet for a few seasons with a stock bike, only fog mod done. Bike was a little softer up there, but still had plenty to go up through the 10,000 ft passes with only a down shift to 5th if you were trying, but generally could cruise in 6th at 60 or higher no problem, no bog.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #9 ·
Hey all, thanks so much for the replies. I did pull apart the petcock about a month ago albeit very poorly and without much knowledge as to what I was doing. As far as I know there is no inline fuel filter, I could not find one and I definitely have not installed one. I just recently replaced my air filter with a foam one and I think next time service is due I'll just throw a K&N in there. I'm 5'9, 190 ish pounds so not too large I don't think. And bpe I do think you may have some merit in saying that because I did not replace them or rebuild them when they were cleaned.

Thank you guys for the help, I feel like no matter the reason it is running pretty darn rich. Seems like I'll have to take a look at the petcock and just rebuild the carb with some fresh rubber parts.
 
1 - 9 of 9 Posts
Top