Ex-500.com - The home of the Kawasaki EX500 / Ninja 500R banner
1 - 12 of 12 Posts

·
Registered
Joined
·
152 Posts
check your tail, rear signals, and front headlight.

because you've mixed up some wiring you might have blown a fuse as well. If one of the above isn't functioning, check the fuse for it first.

And yes, I'm speaking from experience.
 

·
Registered
Joined
·
2,526 Posts
Hi and welcome aboard rideharddiefast.

I just went to my motorcycle shop and checked what they had in stock ;)

I'm sure you could find many on Evil-Bay or suggestions for online shops from the members here (since we got the best of the whole world) ;D
 

·
Registered
Joined
·
2,390 Posts
rideharddiefast said:
i finally found someone to ask. where did you find the turn signals? i have asked in other sites and they just never responded. O im new by the way so ... HI
A lot of dealer stock I've seen comes from Lockhart Phillips:
http://s7d2.scene7.com/s7ondemand/b...70&vc=instanceName=LockhartPhillipseCatalogLg

Click that link, go to around page 150 of their catalog and shop 'til you drop. They've got pretty much everything I've seen on the shelf anywhere, or at least something close to it.

If for some reason the above link times out, go to their main site and then click on the Catalog link:
http://www.lockhartphillipsusa.com/
 

·
Registered
Joined
·
81 Posts
One issue that ive noticed about flushmounts is that you need to mount them to the fairing somehow (either tape or drilling to the plastic). A shop in chicago sells flushmounts that fit directly into the stock hole for the zx-6 (forget the year, think around 05 or so). They shape seems about on par with what our bike's got, anyone know if stock signals for the zx6 will fit the ex?
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top